package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*TC: (?-s)(.*)$`)
var str = `TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:`
var substitution = "<\1>"
fmt.Println(re.ReplaceAllString(str, substitution))
}