#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*TC: (?-s)(.*)$"
Local $sString = "TC: ENG6_6701" & @CRLF & _
"idMatches:" & @CRLF & _
"" & @CRLF & _
"Close: ENG6_6701" & @CRLF & _
"" & @CRLF & _
"TC: ENG6_7211" & @CRLF & _
"idMatches:"
Local $sSubst = "<\1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)