// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*TC: (?-s)(.*)$").unwrap();
let string = "TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:";
let substitution = "<\\1>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}