using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*TC: (?-s)(.*)$";
string substitution = @"<\1>";
string input = @"TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}