re = /.*TC: (?-s)(.*)$/m
str = 'TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:'
subst = '<\\1>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result