import Foundation
let pattern = #".*TC: (?-s)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<\1>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)