use strict;
my $str = 'TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:';
my $regex = qr/.*TC: (?-s)(.*)$/mp;
my $subst = '<\\1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";