$re = '/.*TC: (?-s)(.*)$/m';
$str = 'TC: ENG6_6701
idMatches:
Close: ENG6_6701
TC: ENG6_7211
idMatches:';
$subst = "<\1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;