import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*TC: (?-s)(.*)$";
final String string = "TC: ENG6_6701\n"
+ "idMatches:\n\n"
+ "Close: ENG6_6701\n\n"
+ "TC: ENG6_7211\n"
+ "idMatches:";
final String subst = "<\\1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}