package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\s*\(\d+\)`)
var str = `code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}