import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s*\\(\\d+\\)";
final String string = "code (2021)\n"
+ "names (2021)\n"
+ "all the info you need (AIYN) from A to Z\n"
+ "some info you need (SIYN) from A to Z";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}