// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\s*\(\d+\)").unwrap();
let string = "code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}