const regex = /\s*\(\d+\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\s*\\(\\d+\\)', 'gm')
const str = `code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);