use strict;
my $str = 'code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z';
my $regex = qr/\s*\(\d+\)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";