$re = '/\s*\(\d+\)/m';
$str = 'code (2021)
names (2021)
all the info you need (AIYN) from A to Z
some info you need (SIYN) from A to Z';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;