import re
regex = re.compile(r"\s*\(\d+\)", flags=re.MULTILINE)
test_str = ("code (2021)\n"
"names (2021)\n"
"all the info you need (AIYN) from A to Z\n"
"some info you need (SIYN) from A to Z")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)