using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:'|\"")\${(\d):.*?}(?:'|\"")";
string substitution = @"$\g<1>$";
string input = @"import configparser
configIni = configparser.ConfigParser()
configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}