use strict;
my $str = 'import configparser
configIni = configparser.ConfigParser()
configIni.read(\'${1:example.ini}\')configIni.read(\'${2:example2.ini}\')';
my $regex = qr/(?:'|\")\${(\d):.*?}(?:'|\")/p;
my $subst = '$\\g<1>$';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";