const regex = new RegExp('(?:\\'|\\")\\${(\\d):.*?}(?:\\'|\\")', 'g')
const str = `import configparser
configIni = configparser.ConfigParser()
configIni.read('\${1:example.ini}')configIni.read('\${2:example2.ini}')`;
const subst = `$\g<1>$`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);