import Foundation
let pattern = #"(?:'|\")\${(\d):.*?}(?:'|\")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
import configparser
configIni = configparser.ConfigParser()
configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$\g<1>$"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)