package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:'|\")\${(\d):.*?}(?:'|\")`)
var str = `import configparser
configIni = configparser.ConfigParser()
configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')`
var substitution = "$\g<1>$"
fmt.Println(re.ReplaceAllString(str, substitution))
}