import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:'|\\\")\\$\\{(\\d):.*?\\}(?:'|\\\")";
final String string = "import configparser\n"
+ "configIni = configparser.ConfigParser()\n"
+ "configIni.read('${1:example.ini}')configIni.read('${2:example2.ini}')";
final String subst = "$\\g<1>$";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}