# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*/<i>$1<\/i>/gm;t' <<< "*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END"