#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*"
Local $sString = "*This is my text<br>* Some other text" & @CRLF & _
"*This is my text*<br>Some other text<br>And again *italic*<br>END"
Local $sSubst = "<i>$1</i>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)