const regex = /\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\*[^*]*<br>\\*(*SKIP)(*F)|\\*([^*]*)\\*', 'gm')
const str = `*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END`;
const subst = `<i>$1</i>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);