$re = '/\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*/m';
$str = '*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END';
$subst = "<i>$1</i>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;