use strict;
my $str = '*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END';
my $regex = qr/\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*/mp;
my $subst = '<i>$1</i>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";