using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*";
string substitution = @"<i>$1</i>";
string input = @"*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}