import re
regex = re.compile(r"\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*", flags=re.MULTILINE)
test_str = ("*This is my text<br>* Some other text\n"
"*This is my text*<br>Some other text<br>And again *italic*<br>END")
subst = "<i>$1</i>"
result = regex.sub(subst, test_str)
if result:
print(result)