re = /\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*/m
str = '*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END'
subst = '<i>$1</i>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result