package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*`)
var str = `*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END`
var substitution = "<i>$1</i>"
fmt.Println(re.ReplaceAllString(str, substitution))
}