import Foundation
let pattern = #"\*[^*]*<br>\*(*SKIP)(*F)|\*([^*]*)\*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
*This is my text<br>* Some other text
*This is my text*<br>Some other text<br>And again *italic*<br>END
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<i>$1</i>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)