import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\*[^*]*<br>\\*(*SKIP)(*F)|\\*([^*]*)\\*";
final String string = "*This is my text<br>* Some other text\n"
+ "*This is my text*<br>Some other text<br>And again *italic*<br>END";
final String subst = "<i>$1</i>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}