# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(• )(.+?)(<br>|)(\n)/<li>\2<\/li>\n/g;t' <<< "<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>"