# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(• )(.+?)(<br>|)(\n)"
test_str = ("<ul>\n"
" • This is some random text.<br>\n"
" • This is some other random text.<br>\n"
" • This is another random text.\n"
"</ul>")
subst = "<li>\\2</li>\\n"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.