import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(• )(.+?)(<br>|)(\\n)";
final String string = "<ul>\n"
+ " • This is some random text.<br>\n"
+ " • This is some other random text.<br>\n"
+ " • This is another random text.\n"
+ "</ul>";
final String subst = "<li>\\2</li>\\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}