package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(• )(.+?)(<br>|)(\n)`)
var str = `<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>`
var substitution = "<li>\2</li>\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}