const regex = /(• )(.+?)(<br>|)(\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(• )(.+?)(<br>|)(\\n)', 'g')
const str = `<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>`;
const subst = `<li>\2</li>\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);