$re = '/(• )(.+?)(<br>|)(\n)/';
$str = '<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>';
$subst = "<li>\2</li>\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;