import Foundation
let pattern = #"(• )(.+?)(<br>|)(\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<li>\2</li>\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)