using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(• )(.+?)(<br>|)(\n)";
string substitution = @"<li>\2</li>\n";
string input = @"<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}