// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(• )(.+?)(<br>|)(\n)").unwrap();
let string = "<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>";
let substitution = "<li>\\2</li>\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}