re = /(• )(.+?)(<br>|)(\n)/
str = '<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>'
subst = '<li>\\2</li>\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result