#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(• )(.+?)(<br>|)(\n)"
Local $sString = "<ul>" & @CRLF & _
" • This is some random text.<br>" & @CRLF & _
" • This is some other random text.<br>" & @CRLF & _
" • This is another random text." & @CRLF & _
"</ul>"
Local $sSubst = "<li>\2</li>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)