use strict;
my $str = '<ul>
• This is some random text.<br>
• This is some other random text.<br>
• This is another random text.
</ul>';
my $regex = qr/(• )(.+?)(<br>|)(\n)/p;
my $subst = '<li>\\2</li>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";