# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/:\/\/[^.:]+/:\/\/{HOST_NAME}/g;t' <<< "http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test"