use strict;
my $str = 'http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test';
my $regex = qr~://[^.:]+~p;
my $subst = '://{HOST_NAME}';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";