import Foundation
let pattern = #"://[^.:]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"://{HOST_NAME}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)