import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "://[^.:]+";
final String string = "http://localhost:8080/test\n"
+ " -> http://{HOST_NAME}:8080/test\n"
+ "https://test-app.uk.ru/test\n"
+ " -> https://{HOST_NAME}.uk.ru/test";
final String subst = "://{HOST_NAME}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}