re = /:\/\/[^.:]+/
str = 'http://localhost:8080/test
-> http://{HOST_NAME}:8080/test
https://test-app.uk.ru/test
-> https://{HOST_NAME}.uk.ru/test'
subst = '://{HOST_NAME}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result